8535.com-新浦京娱乐场官网|欢迎您

【新浦京娱乐场官网】Ubuntu 7.10下编译安装pidgi

来源:http://www.dnamique.com 作者:计算机网络 人气:98 发布时间:2019-10-07
摘要:下载 Pidgin 的源代码包 pidgin-2.2.2.tar.bz2 (最新的官方版本)。 Ubuntu7.10下安装编译 Pidgin 所需的依赖: sudo apt-get install libgtk2.0-dev libxml2-dev gettext libnss-devlibnspr-dev 解压源代码包 tar jxvf p
  1. 下载 Pidgin 的源代码包 pidgin-2.2.2.tar.bz2 (最新的官方版本)。

  2. Ubuntu 7.10下安装编译 Pidgin 所需的依赖:
    sudo apt-get install libgtk2.0-dev libxml2-dev gettext libnss-dev libnspr-dev

  3. 解压源代码包
    tar jxvf pidgin-2.2.2.tar.bz2

可能需要先卸载gaim可用“新立得软件包管理器”查找删除。

基础编译工具:build-essential包。//这是基础的编译工具,没有它你什么都做不了;
pidgin依赖的软件包:gettext,libglib2.0-dev,libxml2-dev,libgtk2.0-dev
可选支持:libnss-dev,libnspr-dev,libgstreamer0.10-dev,libgtkspell-dev,libperl-dev,libsasl2-dev,libgnutls-dev,tcl8.4-dev
需要说明的是:libnss-dev和libnspr-dev是保证MSN和Google-Talk插件运行所必须的。没有安装这两个包pidgin 就无法支持MSN和Google-talk。其它的可选包都是支持pidgin的其它特性的不是编译必须的。不过我个人觉得这些功能对于pidgin还是比较有用的,装上为好。
以上所有为编译而准备的开发库都可以在synaptic(新立得软件包管理器)下找到并安装。

4,在Ubuntu 7.10下安装
安装的时候有可能会出现
You must have the GTK+ 2.0 development headers installed to compile Pidgin.
If you only want to build Finch then specify –disable-gtkui when running configure.
解决方法:先
sudo apt-get install libgtk2.0-dev 新浦京娱乐场官网 1

本文由8535.com-新浦京娱乐场官网|欢迎您发布于计算机网络,转载请注明出处:【新浦京娱乐场官网】Ubuntu 7.10下编译安装pidgi

关键词:

频道精选

最火资讯